TR Register Forum

The TR Register Australia Inc. forum dedicated to Sidescreen TRs and Derivatives
It is currently Tue Sep 22, 2020 3:25 am

All times are UTC + 10 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Poor idling
PostPosted: Fri Dec 06, 2019 6:35 pm 
Offline

Joined: Wed Dec 18, 2013 5:05 pm
Posts: 326
I went to Bayview (about 40km away across the centre of Sydney) in the TR2 today and got caught in traffic on the way home, about an hour of stop start stuff.
The engine was heat soaked but the electric fan kept the gauge in the middle.
When the engine gets hot after about half an hour the car doesn't idle well. The first half an hour or so it idles at 800rpm but when it gets really heat soaked the idle will be at 800rpm for maybe 10 seconds after stopping in the traffic and then it drops to 500-650rpm and very rough. It doesn't stall or even feel like it will but it isn't right. I usually juggle the brake/throttle to keep the revs at 800-1000.
If I bump the idle up it then idles too fast for the half an hour before the engine gets really heat soaked.
It feels like the engine is rich cutting, but the mixture is right for normal driving.
Any ideas?


Top
 Profile  
 
 Post subject: Re: Poor idling
PostPosted: Wed Dec 11, 2019 8:46 am 
Offline

Joined: Fri Dec 20, 2013 10:19 am
Posts: 178
Watching. Where are all the answers. I presume that this is the green car in which case the obvious answers don't apply. Watching.


Top
 Profile  
 
 Post subject: Re: Poor idling
PostPosted: Wed Dec 11, 2019 9:46 am 
Offline

Joined: Wed Dec 18, 2013 5:05 pm
Posts: 326
Thanks Terry. It is the BRG daily driver. The car has done this for many many years and I have ignored it, but now I live in the inner west I have more longer drives in heavier traffic.
UK Register members have provided a number of replies to the same question.
This is a common problem for their cars, the high heat under the bonnet causing a too rich mixture. I have leaned the mixture and obtained a better idle but then the mixture is too lean for normal driving with all the consequences.
They have solved it by installing a small fan in front of or next to the radiator with ducting to take cooler air to the carbies. Quite a few have done it and it seems to work.


Top
 Profile  
 
 Post subject: Re: Poor idling
PostPosted: Wed Dec 11, 2019 8:46 pm 
Offline

Joined: Fri Dec 20, 2013 10:19 am
Posts: 178
I see.It is the BRG car but has been doing it for years. OK it relates to early vapor lock/vaporisation which is part of heat and carburetor. Made worse with ULP. Modern cars avoid it with engine management systems. and fuel injection under pressure. OK the Brits add add a little EMS via an auxiliary fan and some say an electric fuel pump helps. Some believe in 10% diesel which burns cooler. Of course you can just accept it because the next step is stalling and the next step then is failure to restart for some time. I had a car that did that; Jenny used to go shopping. There is also the possibility of a failing coil. That also results in a failure to restart after heating up and sometimes a rough idle. My car does it though the idle drops without it being rough. I can raise the idle but then it recovers and runs on badly when I switch off. All part of old cars.


Top
 Profile  
 
 Post subject: Re: Poor idling
PostPosted: Thu Dec 12, 2019 11:22 am 
Offline

Joined: Fri Dec 20, 2013 7:13 pm
Posts: 63
Monty has the same problem but as we mostly tour, run the idle at 900-1000, so when hot idles at 600-700. Now I have just had flywheel and pressure plate rebalanced, small vibrations I was getting went and idle nice and smooth without changing the tuning. Another solution is move to less traffic area or out of Sydney which is becoming a traffic nightmare. Rusty


Top
 Profile  
 
 Post subject: Re: Poor idling
PostPosted: Mon Dec 16, 2019 2:29 pm 
Offline

Joined: Fri Dec 20, 2013 7:48 am
Posts: 110
I have had the same problem twice over the decades. The first was worn carburetters which I fixed with a complete rebuild. The second was a bit more obscure. I had installed an inline filter and it was too close to the engine. The fuel was basically boiling as it only moved slowly through the filter. I moved the filter and it went away. Worth a look.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 10 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group